Facebook Twitter RSS Feed      

WNRO GL1 Clock Error/Sat Fixes Workaround   

WNRO GL1 Clock Error/Sat Fixes Workaround

Postby treysis » Wed May 29, 2019 5:31 pm

A lot of people who have older devices (Rider, One XL, One 3rd Edition etc) are now experiencing problems with their clocks showing 00:00 and also getting satellite fixes after the well publicized WNRO (GPS World Number Rollover) event on 6th April 2019. The problem is due to the GL1 chip on the circuit board of these devices and it is non-replaceable.

However, I have been working on a possible fix for this problem and have had positive results from the people who have tested it so far. You are welcome to try it for yourself but be aware that it's still in development and therefore I may issue updates to the files as time goes by. All of the files and instructions for use are contained in the archive below:

ttconv - Version 11.0

This board requires you to be registered and logged-in to view hidden content.
treysis offline


Junior Member



 
Joined: Mon Dec 10, 2012 7:36 pm
Posts: 10
Has thanked: 1 time
Been thanked: 27 times

Re: WNRO GL1 Clock Error/Sat Fixes Workaround

Postby justbrowsing » Wed May 29, 2019 7:41 pm

justbrowsing offline


Junior Member



 
Joined: Sun Mar 20, 2011 9:36 am
Posts: 15
Has thanked: 37 times
Been thanked: 4 times

Re: WNRO GL1 Clock Error/Sat Fixes Workaround

Postby AKUHE » Wed May 29, 2019 8:11 pm

:023: :023: :023:
AKUHE offline


Junior Member



 
Joined: Fri May 06, 2011 11:05 pm
Posts: 16
Has thanked: 2 times
Been thanked: 0 time

Re: WNRO GL1 Clock Error/Sat Fixes Workaround

Postby treysis » Thu May 30, 2019 12:56 pm

Post #1 updated to version 9.0

Changelog ttconv v9 (29-05-2019):
-fixed memory leak in ttconv and cosmetic changes for rare NMEA sentences
-remove ResetGPS menu icon (only TTconv is left for now)
treysis offline


Junior Member



 
Joined: Mon Dec 10, 2012 7:36 pm
Posts: 10
Has thanked: 1 time
Been thanked: 27 times

Re: WNRO GL1 Clock Error/Sat Fixes Workaround

Postby julien33500 » Thu May 30, 2019 1:19 pm

super! on my one xl with 9.17SE. tank you very much!!!!
julien33500 offline


Junior Member



 
Joined: Sun Jun 03, 2018 1:19 pm
Posts: 3
Has thanked: 25 times
Been thanked: 0 time

Re: WNRO GL1 Clock Error/Sat Fixes Workaround

Postby Charlie62 » Thu May 30, 2019 2:28 pm

julien33500 wrote:super! on my one xl with 9.17SE. tank you very much!!!!

Do you use the 9.17 SE or 9.170 SE navcore with your One XL?
Charlie62 offline


Junior Member



 
Joined: Fri May 21, 2010 10:37 pm
Posts: 24
Has thanked: 2 times
Been thanked: 9 times

Re: WNRO GL1 Clock Error/Sat Fixes Workaround

Postby julien33500 » Thu May 30, 2019 3:54 pm

Bonsoir! I use 9.17 se.
julien33500 offline


Junior Member



 
Joined: Sun Jun 03, 2018 1:19 pm
Posts: 3
Has thanked: 25 times
Been thanked: 0 time

Re: WNRO GL1 Clock Error/Sat Fixes Workaround

Postby Charlie62 » Thu May 30, 2019 4:42 pm

julien33500 wrote:Bonsoir! I use 9.17 se.

Merci. Do you know where I could find it? I found and tested the 9.170 SE, but the treysis fix does not work with it.
Charlie62 offline


Junior Member



 
Joined: Fri May 21, 2010 10:37 pm
Posts: 24
Has thanked: 2 times
Been thanked: 9 times

Re: WNRO GL1 Clock Error/Sat Fixes Workaround

Postby julien33500 » Thu May 30, 2019 6:19 pm

Yes! xxxxxxxxxxxxxx. Bonsoir.
julien33500 offline


Junior Member



 
Joined: Sun Jun 03, 2018 1:19 pm
Posts: 3
Has thanked: 25 times
Been thanked: 0 time

Re: WNRO GL1 Clock Error/Sat Fixes Workaround

Postby Charlie62 » Thu May 30, 2019 6:38 pm

julien33500 wrote:Yes! xxxxxxxxxxxxxxx. Bonsoir.

I could not find it. The search tool is too crappy. Too bad, I will try to find another navcore with which the fix works properly.
Charlie62 offline


Junior Member



 
Joined: Fri May 21, 2010 10:37 pm
Posts: 24
Has thanked: 2 times
Been thanked: 9 times

Re: WNRO GL1 Clock Error/Sat Fixes Workaround

Postby fredderf » Fri May 31, 2019 12:56 pm

Charlie62 wrote:
julien33500 wrote:Bonsoir! I use 9.17 se.

Merci. Do you know where I could find it? I found and tested the 9.170 SE, but the treysis fix does not work with it.


With respect to julien33500, AFAIK there really isn't a 9.17 SE...there is only 9.170 SE so he must mean that one

However, there are people who have used treysis's fix successfully on 9.170 SE see [Please Register or Login to download file] post #387
fredderf offline


Administrator



 
Joined: Sun Nov 17, 2013 2:23 pm
Posts: 2209
Location: UK
Has thanked: 220 times
Been thanked: 2291 times

Re: WNRO GL1 Clock Error/Sat Fixes Workaround

Postby Charlie62 » Sat Jun 01, 2019 6:03 pm

@julien33500, @fredderf and @treysis

I tested ttconv-v9 with the following Navcores on a One XL (SD card, no directory "ephem", map of France 10.25.9386, RAM 32 MB, chipset GL1, emulation One IQ Routes x40light):

9.401 SE: Time = OK. Satellites inside = no. Satellites outside = OK. Available RAM = ± 4.0 MB
9.170 SE: Time = OK. Satellites inside = sometimes. Satellites outside = OK. Available RAM = ± 7.0 MB
9.702 SE/DSA: Time = OK. Satellites inside = no. Satellites outside = OK. Available RAM = ± 10.1 MB
9.541 SE: Time = OK. Satellites inside = no. Satellites outside = OK. Available RAM = ± 11.0 MB.

N. B. A reset is sometimes necessary to be able to restart.

Edit (05/05/19):
I realized that 9.170 SE did not have a swap file, unlike 9.541 and 9.702. With a swap of 8192 KB, it releases up to 14.1 MB of RAM on a One XL!!! It's therefore the most efficient.

Spoiler: Show
Image
Last edited by Charlie62 on Wed Jun 05, 2019 5:59 am, edited 3 times in total.
Charlie62 offline


Junior Member



 
Joined: Fri May 21, 2010 10:37 pm
Posts: 24
Has thanked: 2 times
Been thanked: 9 times

Re: WNRO GL1 Clock Error/Sat Fixes Workaround

Postby cuyaya » Sun Jun 02, 2019 1:53 pm

Hi all. I'm running a One 3rd Edition with 9.541. Formerly, I was on 8.419 (for years without any glitches).

Now 9.541 was kinda working (slow and freezing on startup, but then it worked more or less ok, save for the fact that Treysis' workaround did not seem to work at all and now the unit is cycling on and off after I hit the "resetGPS" menu option out of curiosity.

Tips?
cuyaya offline


Junior Member



 
Joined: Tue Jul 01, 2014 4:20 pm
Posts: 3
Has thanked: 6 times
Been thanked: 0 time

Re: WNRO GL1 Clock Error/Sat Fixes Workaround

Postby Charlie62 » Sun Jun 02, 2019 2:00 pm

@cuyaya

Which version of 9.541 do you use? The original or my SE version including the treysis fix?
Charlie62 offline


Junior Member



 
Joined: Fri May 21, 2010 10:37 pm
Posts: 24
Has thanked: 2 times
Been thanked: 9 times

Re: WNRO GL1 Clock Error/Sat Fixes Workaround

Postby fredderf » Sun Jun 02, 2019 3:21 pm

cuyaya wrote:Hi all. I'm running a One 3rd Edition with 9.541. Formerly, I was on 8.419 (for years without any glitches).

Now 9.541 was kinda working (slow and freezing on startup, but then it worked more or less ok, save for the fact that Treysis' workaround did not seem to work at all and now the unit is cycling on and off after I hit the "resetGPS" menu option out of curiosity.

Tips?


Your device is a 32MB RAM model and NC 9.541 is made for 64MB RAM models so it would make perfect sense that your TT One would be playing up like that if you used the official unmodified NC 9.541.

You should install a NC 9.541 SE version that has been specially modified for use on a 32MB model as Charlie62 is rightly suggesting

Charlie62 wrote:Which version of 9.541 do you use? The original or my SE version including the treysis fix?


Where have you posted that NC mate...I can't see it posted here or have I missed it?
fredderf offline


Administrator



 
Joined: Sun Nov 17, 2013 2:23 pm
Posts: 2209
Location: UK
Has thanked: 220 times
Been thanked: 2291 times

Next

Return to Tutorials

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 0 guests