Facebook Twitter RSS Feed      

help update nuvi 2559lm maps   

help update nuvi 2559lm maps

Postby gugutm » Sun Dec 09, 2018 12:03 pm

Hi Everyone

i need help, please i have nuvi 2559lm with Western Europe NTU it was 2016 but i updated by garmin express to 2019.20 which looks okey, but i want to add Eastern Europe NTU 2019.20 cos i am planning to go to my country , so i download Eastern Europe NTU 2019.20 unlocked img and i placed in ./system/maps folder , but when ever i start my navigation it says cannot unlock maps) :022: :022: :022:

i start reading and find out that my system version is protected which is 8.80 and before update if i remember correctly i had 8.30 which most likely would work, so now i stuck i can not make work Eastern Europe NTU 2019.20 on my nuvi,

i know i need to if i understand correctly downgrade my version to lover like 8.70 and patch it , but there is no much info and its a confusing

can someone help me and redirect to the right post? please

so far what i done i find website where i can download lover sw version [Please Register or Login to download file] i download 8.70 and i remove original GUPDATE from my nuvi and replaced with an older sw but when i start my nuvi i am not getting any message to downgrade .

i stuck please if anyone could help me i would really appreciate it

regards
gugutm
gugutm offline


Junior Member



 
Joined: Sat Apr 30, 2011 12:02 am
Posts: 54
Has thanked: 3 times
Been thanked: 4 times

Re: help update nuvi 2559lm maps

Postby kolokythas » Tue Dec 11, 2018 4:42 am

there is no need to downgrade but to patch your new firmware
kolokythas offline


Moderator



 
Joined: Fri Sep 11, 2015 8:58 am
Posts: 581
Location: Balkans
Has thanked: 21 times
Been thanked: 154 times
Age: 54


Return to General Discussions about Garmin

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 2 guests