Facebook Twitter RSS Feed      

Tutorial on how to get the speedcams for TT working properly   

Tutorial on how to get the speedcams for TT working properly

Postby Downunder35m » Wed Oct 30, 2013 2:44 pm

There has been a lot of confusion in regards to using cam files on Android.
Some say it works but without sound, other say it works but with no icons and the lucky ones simply say it works fine.
So why does it work for some while others can't get it working at all?
1. You need a suitable APK - the ones patched to work with all maps don't give you sound!
Only the versions dedicated to the Android maps will give you sound!
2. You need the right cam files.
3. If it does not work out of the box you have to do it manually!

What do you need and to get it working?
Use the latest version of Winrar (V5) to unpack , previous versions and other packers will cause problems!
Download the archive from [Please Register or Login to download file] - it does not matter for which country you need cams, you only need this archive.
Since a fresh start is the best start, uninstall your TT APK if you already tried to get it working.
For the procedure I assume you did a clean install of APK and content files (like map and so on)!! If not it might not work!
Install the APK and copy the content into the right location, usually the SD root is ok, but some phones need adjustments.
Important! : Some maps already contain speedcam data, I highly recommend using a clean map without any added data, otherwise delete all cam related stuff from the map folder first.
Now start the APK and do you normal settings setup, when done exit the program.
Please follow carefully:
1. From the archive copy only the files Safety_cams_World.bmp, Safety_cams_World.ov2 and Safety_cams_World.ogg to your map folder.
2. Start the APK and do a demo route through a known cam location.
You should see the cam icon on the screen but you get no sound for it (yet).
3. Exit the APK.
4. From the archive copy the remaining files into the map folder.
5. You will be asked to overwrite existing files, so please confirm to overwrite them.
6. Start the APK again and you will have proper speed cam icons on the map including a spoken warning and a distance to the cam shown in the top left corner.
7. In case you don't like the spoken warning you can use a "ding" instead, simply delete the default.ogg and rename the default.ogg-ding to default.ogg

Enjoy!

Troubleshooting:
1. TT complains about a missing network connection.
Make sure the right location for the content folder is used. Also check the install folder if the .metadata.xml is present in the country folder, some have a missing dot at the beginning, if you add the dot it should work fine.
2. I see the cam but don't hear a sound.
Follow the instructions above and make sure tto perform a clean install without any cam files present in the map folder.
3. I want a different sound.
Check the TT website on how to create your own sound - They have a good tut there.
4. Can I add Red light cams?
You can in the same way, but only one type will have a warning sound, the other must be created as normal POI's.
5. Can I use my own or newer cam files?
Although the files are only a few days old, you certainly can replace the cam files with your own.
TT cams that need activation won't work, so you are limited to SCDB and other POI based cam files.
But using a single country file instead of the whole world is possible.
Simply replace both .ov2 files from the archive with your own and make sure to use the same filename as in the archive.
You need a copy for both .ov2 files otherwise it won't work, complain to TT about the troubles ;)

Explanation:
Firstly, no screenshot as I had no time and most likely won't have time for it in the future, but it will work without screenshots ;)
TT still does not support the speedcams as we are used to from the PNA's.
That means even with activation the official TT cams won't work.
The used "default" setup is already built into the APK but not the stuff needed to get them working unless you have the paid APK and use your account to buy cam files.
Having two copies of the cam files under different name is necessary for the APK to correctly show the cam icon and the distance warning on the screen - if you don't see the distance warning or have no sound you did not follow the procedure ;)
Starting the program first with no changed data and only the plain cam files is needed to register the cams in the program,
once that is done the additional files make sure you get the right warning sounds and icons including the distance to the cam.

Questions?
I hope not ;)

Updates can be found here.

Edit:
1. I checked various speed cam files and could not see any magnificent differences, most cam files are getting smaller from one version to the next.
If you find that there are cams missing that are showing on a normal TT let me know, otherwise I don't see a point in updating files that has no significant changes.

2. If you have the cams working properly and you want to update the map, you don't need to install a new APK and you don't need to go through the cam trouble again.
Simply delete the old map files in your map folder, leave the mapsettings.cfg and the related cam files as mentioned here - also delete the DCT file.
Now simply copy the new map files in and all is working fine including the speedcams and your favourites.
Forum rules

[Please Register or Login to download file]

If you find broken links or missing attachments in my postings, please send me PM
Password for all my files: downunder
Downunder35m offline


User avatar Elite Member



 
Joined: Wed Oct 21, 2009 4:44 am
Posts: 4623
Has thanked: 18 times
Been thanked: 516 times

Postby japseye » Thu Oct 31, 2013 2:04 am

The file "Safety_cams_Android_TT.rar" is only 702kb and is corrupt.

Thanks a lot.
japseye offline


Junior Member



 
Joined: Tue Jan 31, 2012 6:33 pm
Posts: 46
Has thanked: 6 times
Been thanked: 12 times

Postby Downunder35m » Thu Oct 31, 2013 4:45 am

Thank you for reporting, but the file works just fine if you use the current version of Winrar to unpack.
Other packers like 7zip and so on will fail to unpack without errors.
Forum rules

[Please Register or Login to download file]

If you find broken links or missing attachments in my postings, please send me PM
Password for all my files: downunder
Downunder35m offline


User avatar Elite Member



 
Joined: Wed Oct 21, 2009 4:44 am
Posts: 4623
Has thanked: 18 times
Been thanked: 516 times

Postby japseye » Thu Nov 07, 2013 10:25 am

This link and the updates pointer link are no longer valid. Filefactory refuses referral from linksave.
japseye offline


Junior Member



 
Joined: Tue Jan 31, 2012 6:33 pm
Posts: 46
Has thanked: 6 times
Been thanked: 12 times

Postby nedkelly » Fri Nov 08, 2013 12:43 am

Works fine for me :-)
nedkelly offline


Junior Member



 
Joined: Mon Nov 21, 2011 5:56 am
Posts: 6
Has thanked: 4 times
Been thanked: 0 time

Postby japseye » Fri Nov 08, 2013 2:17 am

Working now thanks. Must have been a glitch with linksave when I tried earlier.
japseye offline


Junior Member



 
Joined: Tue Jan 31, 2012 6:33 pm
Posts: 46
Has thanked: 6 times
Been thanked: 12 times

Postby pass21 » Tue Nov 26, 2013 1:12 am

Thanx Downunder35m for theTutorial :)

I used Winrar but can not unpack, it said file corrupted :~(
pass21 offline


Junior Member



 
Joined: Tue Nov 19, 2013 8:10 pm
Posts: 8
Has thanked: 2 times
Been thanked: 0 time

Postby Downunder35m » Tue Nov 26, 2013 3:51 am

After so many downloads I highly doubt there is a problem with the file.
Either your download is corrupted or you are using an outdated Winrar version.
Forum rules

[Please Register or Login to download file]

If you find broken links or missing attachments in my postings, please send me PM
Password for all my files: downunder
Downunder35m offline


User avatar Elite Member



 
Joined: Wed Oct 21, 2009 4:44 am
Posts: 4623
Has thanked: 18 times
Been thanked: 516 times

Postby dibsta » Wed Nov 27, 2013 6:56 pm

Hi im trying to download maps but it says The referral link that sent you here is no longer valid.

am i doing something wrong

Dave
dibsta offline


Junior Member



 
Joined: Sun Sep 26, 2010 3:49 pm
Posts: 3
Has thanked: 0 time
Been thanked: 0 time

Postby dibsta » Thu Nov 28, 2013 9:56 pm

dibsta wrote:Hi im trying to download maps but it says The referral link that sent you here is no longer valid.

am i doing something wrong

Dave


Hi is there another link to download

Thanks Dave
dibsta offline


Junior Member



 
Joined: Sun Sep 26, 2010 3:49 pm
Posts: 3
Has thanked: 0 time
Been thanked: 0 time

Postby Downunder35m » Fri Nov 29, 2013 12:44 am

The link is online, so I don't see a problem...
Forum rules

[Please Register or Login to download file]

If you find broken links or missing attachments in my postings, please send me PM
Password for all my files: downunder
Downunder35m offline


User avatar Elite Member



 
Joined: Wed Oct 21, 2009 4:44 am
Posts: 4623
Has thanked: 18 times
Been thanked: 516 times

Postby dibsta » Fri Nov 29, 2013 5:28 pm

Downunder35m wrote:The link is online, so I don't see a problem...


Hi thanks i have managed to get files i used google chrome instead.
Working a treat Sony Xperia Z1

Dave
dibsta offline


Junior Member



 
Joined: Sun Sep 26, 2010 3:49 pm
Posts: 3
Has thanked: 0 time
Been thanked: 0 time

Postby Downunder35m » Sun Dec 15, 2013 12:54 am

I updated the first post in regards to keeping the speedcams and favourites when updating to a new map.
Forum rules

[Please Register or Login to download file]

If you find broken links or missing attachments in my postings, please send me PM
Password for all my files: downunder
Downunder35m offline


User avatar Elite Member



 
Joined: Wed Oct 21, 2009 4:44 am
Posts: 4623
Has thanked: 18 times
Been thanked: 516 times

Re: Tutorial on how to get the speedcams for TT working properly

Postby coucou » Sat Mar 01, 2014 9:14 am

Hello
I have problems to dowload with Linksave.
the link is OK but impossible to dowload

thank
coucou offline


Junior Member



 
Joined: Thu Sep 23, 2010 4:25 pm
Posts: 13
Has thanked: 0 time
Been thanked: 0 time

Re: Tutorial on how to get the speedcams for TT working properly

Postby fdhauto » Sat Apr 05, 2014 6:53 am

hello first big thanks work great ! thank you so much !
When do you think the database will be updated ?
thanks
fred
fdhauto offline


Junior Member



 
Joined: Sun Mar 23, 2014 7:46 am
Posts: 1
Has thanked: 0 time
Been thanked: 0 time

Next

Return to Android Discussion

 


  • Related topics
    Replies
    Views
    Last post

Who is online

Users browsing this forum: No registered users and 2 guests